aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.openwrt
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.openwrt')
-rw-r--r--Makefile.openwrt36
1 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.openwrt b/Makefile.openwrt
new file mode 100644
index 0000000..1c90cfc
--- /dev/null
+++ b/Makefile.openwrt
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=i3ensors
+PKG_VERSION:=1.0
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+PKG_MAINTAINER:=AA <aa@aa.hu>
+PKG_LICENSE:=ISC GPL-2.0
+## PKG_BUILD_DEPENDS:=+madplay
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/i2sensors/default
+ CATEGORY:=Sensors
+ SUBMENU:=I2C Sensors
+ TITLE:=Famous I2C Sensors reader
+endef
+
+define Package/i2sensors
+ $(Package/i2sensors/default)
+ ##DEPENDS:=+uhttpd +uhttpd-mod-lua +uhttpd-mod-tls +kmod-sound-core +kmod-usb-audio +alsa-lib
+endef
+
+define Package/i2sensors/description
+ i2sensors read some i2c devices
+endef
+
+define Package/i2sensors/install
+ $(CP) ./files/* $(1)/
+endef
+
+define Build/Compile
+ true
+endef
+
+$(eval $(call BuildPackage,webclient))
+